ここから本文です

「Zend Framework」にSQLインジェクションの脆弱性(JVN)

ScanNetSecurity 9月16日(金)8時0分配信

独立行政法人 情報処理推進機構(IPA)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は9月15日、Zend Frameworkが提供するオープンソースのWebアプリケーションフレームワークである「Welcart」にSQLインジェクションの脆弱性が存在すると「Japan Vulnerability Notes(JVN)」で発表した。CVSS v3によるBase Scoreは8.1。

「Zend Framework 1.12.20 より前のバージョン」には、ORDER BY句および GROUP BY句の引数の処理が原因でSQLインジェクションの脆弱性(CVE-2016-4861)が存在する。この脆弱性が悪用されると、リモートの第三者によってデータベース内の情報を取得されたり、改ざんされる可能性がある。JVNでは、開発者が提供する情報をもとに最新版へアップデートするよう呼びかけている。

(吉澤 亨史)

最終更新:9月16日(金)8時0分

ScanNetSecurity